Cannot retrieve latest yii2-export

Web Tips Q & ACategory: Krajee Yii2 ExtensionsCannot retrieve latest yii2-export
Anonymous asked 2 years ago

Hi Kartik, I’ve recently facing issue with updating yii2-export extension from 1.2.2 to 1.2.4.when i install yii2 basic application from scratch and directly require kartik-v/yii2-export “@dev“, it installs v1.2.4 but when i update my old project, it says “nothing to install or update” from composer message and stay at 1.2.2. Even if i remove yii2-export and re-require it back, it always install v1.2.2.i also have deleted composer cache, follow your tips about “composer fail update” to clear vendor and composer.lock. It still stay at v1.2.2.

1 Answers
Kartik Staff answered 2 years ago

You need to check composer.json settings and dependencies in your old project. Seems there is some caching issue of some outdated composer package data. Backup your vendor folder and try entirely removing the vendor folder and then remove composer.lock and run

composer install --prefer-dist

 

Login or register to contribute or comment.

Login   Register